Uncategorized

POPOS 20.10 – Problemas com as fontes do Google?

Estou passando rapidinho porque depois de tentar fazer um projeto rodar na minha máquina onde estava rodando o Ubuntu 20.04 que uso a vários anos e é, pra mim, o melhor que existe. Tive de formatar minha máquina porque fiz zorra demais no sistema e resolvi usar novamente (porque já usei em máquinas de trabalho algumas vezes) o POPOS 20.10.

A primeira impressão é muito boa. Algumas funcionalidades são muito legais, como um gerenciador de janelas, como na interface I3W você consegue gerenciar janelas quando usa esse modo na sua interface. Basta clicar no ícone na barra superior do sistema.

Clicar na janelinha acima que as bordas estão em vermelho ao lado direito do relógio.

Também existem vários outros detalhes e o mais importante é a estabilidade do Sistema de base alterada do Ubuntu e que tem um excelente gerenciamento de memória, processamento, coolers e outros pontos do sistema. Mas não estou aqui para falar sobre o PopOS 20.10, pra isso o Youtube tá cheio de vídeos pra você conhecer.

Eu vou falar sobre coisas que geralmente você não encontra lá. Primeiro que ele usa o FlatPak ao invés do Snap (que eu realmente não entendo porque insistem nele no Ubuntu), mas também respeita sua escolha com pacotes deb. A central de software dele trabalha muito melhor que no Ubuntu. Rápida, cheia de opções, etc.

Mas a primeira dica é quando for fazer o download. Se você não possui uma placa NVidia na sua máquina não tem porque ficar instalando os drivers dela. Então quando for fazer o download, olhe com cuidado e veja que tem duas versões. Uma dedicada para placas Intel e outra pra Placas NVidia.

Se liga nos dois campos de download. Ele geralmente já detecta e indica.

Problemas com Renderização de fonte no Google Chrome com PopOS.

Agora vem o prato principal. Você, vai reparar como eu quando instalar o Google Chrome que a fonte da maior parte dos Sites que não possui uma fonte definida ou é implementada de forma dinâmica fica estranha. Tipo comprimida (eu acabei não dando print nela pra mostrar errada).

Isso acontece porque o PopOS 20.10 não colocou (ainda) na Distro a fonte “Arial”, usada pelo Navegador para renderizar fontes desconhecidas nas páginas. Então para resolver, você só precisa instalar a fonte “Arial” no seu PopOS.

Pra você não ter o trabalho de ficar procurando ele pra baixar eu vou deixar aqui meu repositório de fontes do meu github. Eu tenho esse repositório com fontes que uso no sistema e também para editores de código e scripts. Enfim. Segue ai e vc pode clonar ou baixar e instalar na sua máquina. As fontes Arial estão lá pra você resolver também seu problema.

https://github.com/thiagolucio/code-editor-fonts

Se vc não sabe como fazer isso, existem duas formas. A primeira é clicando em cima da fonte duas vezes e o gerenciador de fontes abre e vc clica em instalar.

A outra forma é criar uma pasta chamada “fonts”, dentro da pasta “.local/share/” da sua “home” e jogando as fontes lá dentro. Mas para que o sistema possa enxergar as fontes você deverá rodar no terminal o comando abaixo:

sudo fc-cache -f -v

Assim o Sistema vai rodar o recarregamento de leitura das fontes de texto do sistema. Depois disso feche e abra novamente seu Navegador Chrome e “Voilá”. Seu Chrome estará com as fontes bacanas novamente.

PS: No caso deste problema, não vai adiantar personalizar as fontes do chrome em “Aparência” porque neste caso é só para as fontes de texto das janelas e menus. Este é um caso específico e só assim mesmo pra resolver. Porque até mesmo se você editar o arquivo CSS do Chrome na sua pasta home dentro de config, quando ele atualizar vai sobscrever o arquivo. Além do mais várias outras coisas podem usar e aí melhor já ter.

Você também pode esperar que os Desenvolvedores do PopOS arrumem esse problema nas próximas atualizações porque já abri uma Issue para resolver isso com eles.

No mais é isso rapaize…Grande abraço e se não rolar mais um post em breve, Feliz Natal e Ano novo!

Padrão